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Windows Server 2008 R2出现termdd蓝屏问题,如何处理?

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本文介绍Windows Server 2008 R2出现termdd蓝屏问题的原因及解决方案。

问题描述

Windows Server 2008 R2在运行过程中出现termdd(错误代码是0x000000D1或者其他)蓝屏问题,如下图所示。

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且Dump信息中显示termdd.sys(C:\Windows\System32\drivers\termdd.sys)文件的版本在6.1.7601.24441以下。

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问题原因

是系统漏洞导致。微软于2019年05月14日修复了该漏洞,CVE详细信息请参考CVE-2019-0708。 

解决方案

  1. 更新系统。

    Windows自动更新系统

    使用Windows更新,将系统更新至最新。

    1. 远程连接ECS实例。

      具体操作,请参见通过密码或密钥认证登录Windows实例

    2. 修改注册表中的WSUS地址。

      1. 依次选择开始 > 运行 > regedit

      2. 进入计算机\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate路径,将WUServerWUStatusServer的值修改为

        http://update.cloud.aliyuncs.com

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    3. 依次选择开始 > 控制面板 > 系统和安全 > Windows Update

    4. 扫描更新后,单击安装更新

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    5. 更新完成后,重启Windows系统。

    手动更新系统

    1. 远程连接ECS实例。

      具体操作,请参见通过密码或密钥认证登录Windows实例

    2. 下载累计安全补丁KB4499164或者仅安全更新补丁KB4499175

    3. 双击安装补丁。

    4. 重启Windows系统。

  2. 验证问题是否修复。

    • 查看已安装的补丁。

      自动更新系统或者手动更新系统后,打开CMD命令行,使用systeminfo命令查看已安装的补丁,确认系统安装了KB4499164或者KB4499175补丁。

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    • 查看termdd.sys文件版本。

      确认termdd.sys(C:\Windows\System32\drivers\termdd.sys)文件版本是否在6.1.7601.24441及以上。

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    如果确认系统安装了KB4499164或者KB4499175补丁以及termdd.sys文件版本在6.1.7601.24441及以上,蓝屏问题解决。

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